Performance Probleme bei diversen Spielen (GBA/SNES)

Alles über verschiedenste Emulatoren.
Antworten
Autor
Nachricht
Benutzeravatar
Retribute
7 Bit
Beiträge: 171
Registriert: Mi Feb 02, 2011 15:49
Wohnort: NRW

Performance Probleme bei diversen Spielen (GBA/SNES)

#1 Beitrag von Retribute » Fr Feb 18, 2011 17:22

Hallo!

habe ziemliche Probleme mit einigen Spielen.

z.B
Golden Sun (GBA)
FPS 30-60
der Ton stockt gerade in Kämpfen sehr stark.
selbst mit 800Mhz ist es mehr oder weniger unspielbar.
bei jeder Attacke sinken die FPS auf ~30.

Final Fantasy VI (SNES)
der Ton spielt völlig verrückt.
es klingt so als wird alles mehrfach abgespielt - daraus entsteht dann eine Art Echo.
je nach Ton wird dann alles zu einem großen Rauschen.

oder aber der Ton ist plötzlich komplett weg.

Chrono Trigger (SNES)
hier passiert in etwa das gleiche wie bei FF VI.

auch bei FF I II V für's SNES und den GBA habe ich nur sehr wenige FPS und der Ton ist durchgehend schrecklich.




liegt das nur an den (schlechten) Emulatoren ?
gibt es Tricks um die Spiele spielbar zu machen ?
oder ist das alles normal und ich muss mich damit abfinden ?
Zuletzt geändert von Retribute am Fr Feb 18, 2011 17:41, insgesamt 1-mal geändert.

Benutzeravatar
secondakira
4 Bit
Beiträge: 18
Registriert: Sa Mai 16, 2009 22:07

Re: Performance Probleme bei diversen Spielen (GBA/SNES)

#2 Beitrag von secondakira » Fr Feb 18, 2011 17:41

Also, mit Golden Sun habe ich keine Erfahrung, aber sowohl Final Fantasy (du meinst wahrscheinlich VI) als auch Chrono Trigger liefen bei mir hervorragend.
Welche Version von PocketSnes benutzt du denn?
Und was für Einstellungen verwendest du?

Benutzeravatar
Retribute
7 Bit
Beiträge: 171
Registriert: Mi Feb 02, 2011 15:49
Wohnort: NRW

Re: Performance Probleme bei diversen Spielen (GBA/SNES)

#3 Beitrag von Retribute » Fr Feb 18, 2011 17:50

meine natürlich V nicht X - böse Römer. ;)


ich nutze PocketSnes v. 7.1.0 ( http://dl.openhandhelds.org/cgi-bin/wiz ... 0,0,71,479 )
und gpSP 0.9-2Xb-u6 ( http://dl.openhandhelds.org/cgi-bin/wiz ... 0,0,71,101 )

gpSP Einstellungen
scaled 3:2 anti-tear
Frameskip type: auto / value:2 / variation: uniform

Audio buffer: 2048 bytes (hat anscheinend überhaupt keine Auswirkung auf Sound oder FPS)

533-800 Mhz.

kann verändern was ich will, es ruckelt weiter.
gerade Golden Sun lässt sich von anderen Einstellungen garnicht beeindrucken.
der Ton ist einfach nur schlimm.



PocketSNES

Sound Rate: 22k mono
Frameskip: auto
Region: auto
Transparencies: ON (OFF bringt auch nicht viel - teilweise mehr FPS aber der Ton bleibt halt unerträglich)
CPU Speed: 533-800
Render Mode: scaled

Benutzeravatar
secondakira
4 Bit
Beiträge: 18
Registriert: Sa Mai 16, 2009 22:07

Re: Performance Probleme bei diversen Spielen (GBA/SNES)

#4 Beitrag von secondakira » Fr Feb 18, 2011 19:44

Hab eben mal Chrono Trigger angetestet, und zwar mit meinen Standardeinstellungen:

PocketSnes 6.5.0

Sound Rate: 44100 stereo
Transparencies: ON
Cpu Speed: 540
Emulation: Fast
Audio Performance Hack: ON

Das Spiel läuft einwandfrei, konstant hohe Framerate und klarer Sound.
Hab danach noch mal PocketSnes 7.1.0 probiert, und da ist zwar die Framerate auch hoch, aber der Sound ist tatsächlich fehlerhaft. Also probier es am besten mal mit 6.5.0

Benutzeravatar
Retribute
7 Bit
Beiträge: 171
Registriert: Mi Feb 02, 2011 15:49
Wohnort: NRW

Re: Performance Probleme bei diversen Spielen (GBA/SNES)

#5 Beitrag von Retribute » Fr Feb 18, 2011 20:33

wow!

Chrono Trigger läuft
FF VI auch

und selbst das Mario RPG startet.

Vielen Dank !
wer hätte gedacht das die alte Version besser läuft als die neue.



hat denn noch jemand eine Idee was man beim GBA Emulator machen könnte ?

budi777
3 Bit
Beiträge: 8
Registriert: Do Nov 11, 2010 16:01

Re: Performance Probleme bei diversen Spielen (GBA/SNES)

#6 Beitrag von budi777 » Mi Apr 27, 2011 12:47

also ich nutz im Moment Pocketsnes 7.2.0 also die ganz neue Version. Als ich dann versucht habe Final Fantasy VI zu spielen hab ich mich erst
gefreut, dass es so flüssig lief, dann war ich aber entäuscht, als das Spiel nach dem ersten Kampf einfach abstürzte :-(( :-(( kann mir irgendjemand weiterhelfen, ich möchte das spiel wirklich umbedingt zocken :wiz:
:wiz: 4 EVER!!!!

Benutzeravatar
knotenpunkt
9 Bit
Beiträge: 969
Registriert: Do Dez 18, 2008 18:04
Wohnort: Bochum

Re: Performance Probleme bei diversen Spielen (GBA/SNES)

#7 Beitrag von knotenpunkt » Mi Apr 27, 2011 13:42

Naja, dann nimm doch einfach wieder die 6.5.0er Version von PocketSNES.

Antworten

Zurück zu „Wiz - Emulation“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast