Ordner mit ä ö ü werden nicht angezeigt.

Probleme mit der Pandora oder der Software? Hier gibts Hilfe!
Autor
Nachricht
Mevolu
2 Bit
Beiträge: 4
Registriert: Mi Jul 24, 2013 08:40

Ordner mit ä ö ü werden nicht angezeigt.

#1 Beitrag von Mevolu » Mi Jul 24, 2013 08:52

Hallo,

ich bin schon seit längerem auf der Suche ein Problem mit der Pandora zu lösen. Habe bisher aber kein Erfolg gehabt weshalb ich es hier mal versuche.

Mein Problem:

Ich habe meine Musiksammlung auf SD-Karte kopiert um sie immer dabei zu haben. Im Dateimanager werden alle Ordner und Dateien auch richtig angezeigt. Wenn ich jetzt aber VLC nutze um die Musik abzuspielen und im Player eine Datei öffnen will, werden mir nur die Ordner ohne ä ö und ü Inhalte angezeigt. Auch per draganddrop vom Dateimanger bringt nichts. Das gleiche gilt auch für Audacious. Wenn ich ein Lied in die Playlist schmeiße wird es nicht abgespielt. Nun möchte ich nicht alle meine Lieder wo ein ä ö oder ü kommt einzelnt ändern. Gibt es da eine einfache Lösung?

Klumpen
10 Bit
Beiträge: 1636
Registriert: Sa Nov 19, 2011 14:12

Re: Ordner mit ä ö ü werden nicht angezeigt.

#2 Beitrag von Klumpen » Mi Jul 24, 2013 09:19

Du könntest um in Zukunft weitere Kompatiblitätsprobleme zu beheben auch einfach das
"Bulk Rename Utility" nehmen und bei allen Dateien in deinem Musikarchiv automatisch "ä" zu "ae",
"ü" zu "ue" und "ö" zu "oe" ändern lassen.

Benutzeravatar
Raik
Forum Team
Forum Team
Beiträge: 1049
Registriert: Mi Nov 07, 2012 19:19
Wohnort: Nhg.
Kontaktdaten:

Re: Ordner mit ä ö ü werden nicht angezeigt.

#3 Beitrag von Raik » Mi Jul 24, 2013 09:33

Ich bin nicht sicher, ist schon eine Weile her und aktuell benutze ich DeaDBeeF.
Ich bin mir sicher das bei mir Lieder mit Umlauten im Titel mit VLC abgespielt wurden.
Ich erinnere mich dunkel, daß ich bei der "Ersteinrichtung" an mehreren Stellen die verwendeten Zeichensätze angepasst habe. ClawMail sendet im mit den Voreinstellungen z.B. auch keine Umlaute...

Benutzeravatar
Fusion_Power
12 Bit
Beiträge: 5963
Registriert: So Dez 25, 2005 16:33
Wohnort: zu Hause

Re: Ordner mit ä ö ü werden nicht angezeigt.

#4 Beitrag von Fusion_Power » Mi Jul 24, 2013 14:29

Hab ich auch festgestellt, bzw. bei Liedern mit Sonderzeichen aber erst seit relativ kurzer Zeit, früher wurde das alles tadellos angezeigt auf der Pandora und auch abgespielt (Audacious). Wäre schön, wenn die Player, bzw. die Pandora das wieder hinbekommen würde, hab keine Lust alles umzubenennen, Umlaute und sonderzeichen sollte jedes Programm eigentlich standardmäßig darstellen können.

Mevolu
2 Bit
Beiträge: 4
Registriert: Mi Jul 24, 2013 08:40

Re: Ordner mit ä ö ü werden nicht angezeigt.

#5 Beitrag von Mevolu » Do Jul 25, 2013 06:05

Naja, dann muss ich die erstmal alle umbennen.

Benutzeravatar
Fusion_Power
12 Bit
Beiträge: 5963
Registriert: So Dez 25, 2005 16:33
Wohnort: zu Hause

Re: Ordner mit ä ö ü werden nicht angezeigt.

#6 Beitrag von Fusion_Power » Do Jul 25, 2013 13:28

Es muss ein neuerliches Firmwareproblem sein, denn die Player selber haben wie gesagt früher alles anstandslos abgespielt, egal wie die Files hießen. Jetzt streiken GMU und Audacious bei bestimmten Buchtaben und Sonderzeichen komplett, nur Deadbeef spielt solche Files noch ab. Außer der Firmware hab ich nix verändert, sind noch die selben Mediaplayer Versionen. Ich hab schon mal geschaut ob man irgendwo in den Firmware Settin gs erweiterte Zeichensätze einstellen kann aber bisher nix gefunden, geht bestimmt, ist ja Linux. Vielleicht hat da noch jemand eine Idee?

Benutzeravatar
zLouD
9 Bit
Beiträge: 529
Registriert: So Okt 12, 2008 18:03

Re: Ordner mit ä ö ü werden nicht angezeigt.

#7 Beitrag von zLouD » Do Jul 25, 2013 13:54

Hallo,

also wenn du Dateien auf der mit Umlauten erstellst sollte das funktionieren, wenn du allerdings Dateien mit Umlauten aus anderen Dateisystemen mit rein holst kann es vorkommen dass die Kodierung nicht angenommen wird (von NTFS zu EXT z.B./alte Beispiele bei mir).

Ich empfehle ext4 für die SD-Karten zu nutzen, damit habe ich bislang weitaus weniger Probleme als mit FAT16/32.

Zu deinem Problem: manuell umbenennen wenn es mit automatischen Programmen nicht klappt.
Sei du selbst die Veränderung, die du dir wünschst für diese Welt.
Mohandas Karamchand Gandhi
--
Bild
zLouD.

Mevolu
2 Bit
Beiträge: 4
Registriert: Mi Jul 24, 2013 08:40

Re: Ordner mit ä ö ü werden nicht angezeigt.

#8 Beitrag von Mevolu » Do Jul 25, 2013 15:22

Danke für den Tipp mit Deadbeef. Damit klappt es auch bei mir wunderbar.

Benutzeravatar
Fusion_Power
12 Bit
Beiträge: 5963
Registriert: So Dez 25, 2005 16:33
Wohnort: zu Hause

Re: Ordner mit ä ö ü werden nicht angezeigt.

#9 Beitrag von Fusion_Power » Do Jul 25, 2013 18:05

zLouD hat geschrieben: Zu deinem Problem: manuell umbenennen wenn es mit automatischen Programmen nicht klappt.
Ich möchte die Dateien aber überhaupt nicht umbenennen, früher gings auch (seit jeher Fat32 SD Karten in der Pandora), ich versuche das Problem lieber an der Wurzel zu packen. Irgend was muss sich ja geändert haben, dem würde ich gern auf den grund gehen, geht mir da ehr ums Prinzip (wie so oft :D ).
Mevolu hat geschrieben:Danke für den Tipp mit Deadbeef. Damit klappt es auch bei mir wunderbar.
Ist ein brauchbarer Player, sogar mit Equalizer, leider ohne Presets. Muss ich nmir noch suchen oder selber einstellen. Die presets kann man zumindest irgend wie importieren.

Benutzeravatar
Raik
Forum Team
Forum Team
Beiträge: 1049
Registriert: Mi Nov 07, 2012 19:19
Wohnort: Nhg.
Kontaktdaten:

Re: Ordner mit ä ö ü werden nicht angezeigt.

#10 Beitrag von Raik » Do Jul 25, 2013 19:38

Danke für den Tipp mit Deadbeef. Damit klappt es auch bei mir wunderbar.
Der ist 2 Jahre alt und von ED ;-) Ich war damals der Soundausgabe von VLC nicht zufrieden.
Ich möchte die Dateien aber überhaupt nicht umbenennen, früher gings auch (seit jeher Fat32 SD Karten in der Pandora), ich versuche das Problem lieber an der Wurzel zu packen. Irgend was muss sich ja geändert haben, dem würde ich gern auf den grund gehen, geht mir da ehr ums Prinzip (wie so oft :D ).
Das mit dem Prinzip kenne ich. Eigentlich muß ich mit der Pandora nicht drucken, da es ein Computer ist, muß es gehen. Nachdem es ging, habe ich nie wieder damit gedruckt ;-)

Ich denke die Wurzel ist ein voreingestellter Zeichensatz bzw. -code.

Benutzeravatar
Fusion_Power
12 Bit
Beiträge: 5963
Registriert: So Dez 25, 2005 16:33
Wohnort: zu Hause

Re: Ordner mit ä ö ü werden nicht angezeigt.

#11 Beitrag von Fusion_Power » Fr Jul 26, 2013 00:40

Raik hat geschrieben: Ich denke die Wurzel ist ein voreingestellter Zeichensatz bzw. -code.
Das ist auch meine Theorie aber wie und wo kann man sowas ändern?

Benutzeravatar
zLouD
9 Bit
Beiträge: 529
Registriert: So Okt 12, 2008 18:03

Re: Ordner mit ä ö ü werden nicht angezeigt.

#12 Beitrag von zLouD » Fr Jul 26, 2013 01:47

Fusion_Power hat geschrieben: Das ist auch meine Theorie aber wie und wo kann man sowas ändern?
So zum Beispiel
Sei du selbst die Veränderung, die du dir wünschst für diese Welt.
Mohandas Karamchand Gandhi
--
Bild
zLouD.

Benutzeravatar
Raik
Forum Team
Forum Team
Beiträge: 1049
Registriert: Mi Nov 07, 2012 19:19
Wohnort: Nhg.
Kontaktdaten:

Re: Ordner mit ä ö ü werden nicht angezeigt.

#13 Beitrag von Raik » Fr Jul 26, 2013 12:28

...Wurzel...
Wenn ich heute nacht im Garten sitze versuche ich mal das Folgende...

Im Terminal

printenv

In der Ausgabe sollte dann auch der Zeichensatz erwähnt werden, z.B.
als LANG= (z.B.: LANG=de_DE@euro , was dem ISO Zeichensatz ISO8859-15 entspricht.)

Dann das Verzeichnis /etc durchforsten nach locale-Einstellungen.
Vielleicht gibt auch ein Tool, das fehlende locale Files erzeugen kann.
Unter /usr/sbin/locale-gen ist es unter Debian Linux zu finden...
Der Befehl

apropos locale

im Terminal hilft evtl. auch weiter.

;)

Benutzeravatar
Fusion_Power
12 Bit
Beiträge: 5963
Registriert: So Dez 25, 2005 16:33
Wohnort: zu Hause

Re: Ordner mit ä ö ü werden nicht angezeigt.

#14 Beitrag von Fusion_Power » Mo Jul 29, 2013 00:56

Die Pandora scheint diese Befehle nicht zu kennen, also "printnv" oder was sonst noch erwähnt wurde. hab nur diese fstab gefunden aber da steht nicht viel interessantes drinne

Code: Alles auswählen

# OpenPandora fstab.

rootfs               /                    auto       defaults,noatime      1  1
proc                 /proc                proc       defaults              0  0
devpts               /dev/pts             devpts     mode=0620,gid=5       0  0
usbfs                /proc/bus/usb        usbfs      defaults              0  0
tmpfs                /var/volatile        tmpfs      defaults              0  0
tmpfs                /dev/shm             tmpfs      mode=0777             0  0
tmpfs                /media/ram           tmpfs      defaults              0  0

# The /boot kernel volume on the OpenPandora NAND.

ubi1:boot            /boot                ubifs      defaults
also nix was mit wegen Zeichenkodierung weiterhilft. Aber ich suche weiter.

Benutzeravatar
Raik
Forum Team
Forum Team
Beiträge: 1049
Registriert: Mi Nov 07, 2012 19:19
Wohnort: Nhg.
Kontaktdaten:

Re: Ordner mit ä ö ü werden nicht angezeigt.

#15 Beitrag von Raik » Mo Jul 29, 2013 05:12

Ich habe leider inzwischen auch fetgestellt, daß das was unter Debian funktioniert, unter Angström leider nicht geht.

printenv

funktioniert zwar, gibt aber keinen Hinweis auf die Zeichensatzeinstellung.

Vielleicht sollte man mit grep mal das Muster LANG= suchen um zu sehen ob und wo was definiert ist.
etc/enviroment ist leer. Vielleicht kann man auch dort, wenn man weiß was ;-)

Antworten

Zurück zu „Pandora - Hilfe!“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast