IniMaker - Nun SD Karte defekt

Du hast Probleme? Frage hier - und Dir wird geholfen!
Autor
Nachricht
Benutzeravatar
Screeny
11 Bit
Beiträge: 3903
Registriert: Di Okt 14, 2008 18:48
Wohnort: Wiesbaden

Re: IniMaker - Nun SD Karte defekt

#16 Beitrag von Screeny » Mo Jan 11, 2010 18:11

Das ist eine gute Frage....ich weiß leider nicht genau, wie die "heutige" Knoppix Version aussieht..
Hast du ein Programm namens "QTParted"?
Neues Projekt: Cosvalley.de - Deine Cosplaycommunity

Benutzeravatar
momosxp
8 Bit
Beiträge: 281
Registriert: Di Apr 08, 2008 09:34
Kontaktdaten:

Re: IniMaker - Nun SD Karte defekt

#17 Beitrag von momosxp » Mo Jan 11, 2010 22:31

Ja, das erkennt die SD Karte leider auch nicht :(

Benutzeravatar
Screeny
11 Bit
Beiträge: 3903
Registriert: Di Okt 14, 2008 18:48
Wohnort: Wiesbaden

Re: IniMaker - Nun SD Karte defekt

#18 Beitrag von Screeny » Mo Jan 11, 2010 22:40

Dann seh ich schwarz für deine SD Karte :(
Wie groß / teuer ist die denn?

Wenn es dir wichtig ist, kannst du sie mir ja vllt. auch schicken, ich guck ma, was sich machen lässt.
Rückporto zahle ich ;)
Neues Projekt: Cosvalley.de - Deine Cosplaycommunity

Benutzeravatar
momosxp
8 Bit
Beiträge: 281
Registriert: Di Apr 08, 2008 09:34
Kontaktdaten:

Re: IniMaker - Nun SD Karte defekt

#19 Beitrag von momosxp » Di Jan 12, 2010 00:11

Es ist wie gesagt eine 8gb sandisk micro sd karte.. hatte ich mir damals aus ebay für den WIZ geholt. Ist nichts besonderes drauf gewesen. Eben nur emus, roms,videos usw
Mich ärgert mehr dass sie einfach so mal eben kaputt geht -.-
Hatte alles so schön einheitlich mit den Icons eingerichtet :D
Hab hier noch 2x4gb karten.

IsSuE
6 Bit
Beiträge: 100
Registriert: Do Jan 12, 2006 19:38
Wohnort: Oberoesterreich

Re: IniMaker - Nun SD Karte defekt

#20 Beitrag von IsSuE » Di Jan 12, 2010 01:07

post mal nachem du die sdcard reingesteck hast den output von dmesg | tail

Benutzeravatar
momosxp
8 Bit
Beiträge: 281
Registriert: Di Apr 08, 2008 09:34
Kontaktdaten:

Re: IniMaker - Nun SD Karte defekt

#21 Beitrag von momosxp » Di Jan 12, 2010 09:08

Code: Alles auswählen

knoppix@Microknoppix:~$ dmesg | tail
[   98.854758] [drm] Loading R500 Microcode
[   98.854824] [drm] Num pipes: 1
[   98.854833] [drm] writeback test succeeded in 1 usecs
[  203.975745] wlan0: authenticate with AP 00:1c:f0:e4:49:c5
[  203.977535] wlan0: authenticated
[  203.977540] wlan0: associate with AP 00:1c:f0:e4:49:c5
[  203.980565] wlan0: RX AssocResp from 00:1c:f0:e4:49:c5 (capab=0x431 status=0 aid=2)
[  203.980569] wlan0: associated
[  203.987282] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[  214.080020] wlan0: no IPv6 routers present
knoppix@Microknoppix:~$ dmesg | tail
[   98.854824] [drm] Num pipes: 1
[   98.854833] [drm] writeback test succeeded in 1 usecs
[  203.975745] wlan0: authenticate with AP 00:1c:f0:e4:49:c5
[  203.977535] wlan0: authenticated
[  203.977540] wlan0: associate with AP 00:1c:f0:e4:49:c5
[  203.980565] wlan0: RX AssocResp from 00:1c:f0:e4:49:c5 (capab=0x431 status=0 aid=2)
[  203.980569] wlan0: associated
[  203.987282] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[  214.080020] wlan0: no IPv6 routers present
[  267.708799] usb 1-2: USB disconnect, address 2
knoppix@Microknoppix:~$ dmesg | tail
[  271.213387] usb 1-2: new high speed USB device using ehci_hcd and address 3
[  271.342335] usb 1-2: New USB device found, idVendor=05e3, idProduct=0715
[  271.342342] usb 1-2: New USB device strings: Mfr=3, Product=4, SerialNumber=2
[  271.342347] usb 1-2: Product: USB Storage
[  271.342352] usb 1-2: Manufacturer: Generic 
[  271.342356] usb 1-2: SerialNumber: 000000009412
[  271.342550] usb 1-2: configuration #1 chosen from 1 choice
[  271.343264] scsi6 : SCSI emulation for USB Mass Storage devices
[  271.343846] usb-storage: device found at 3
[  271.343850] usb-storage: waiting for device to settle before scanning
knoppix@Microknoppix:~$ dmesg | tail
[  281.246229] Buffer I/O error on device sdb, logical block 0
[  281.246244] ldm_validate_partition_table(): Disk read failed.
[  281.248450] sd 6:0:0:0: [sdb] Device not ready
[  281.248455] sd 6:0:0:0: [sdb] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[  281.248462] sd 6:0:0:0: [sdb] Sense Key : Not Ready [current] 
[  281.248470] sd 6:0:0:0: [sdb] Add. Sense: Medium not present
[  281.248479] end_request: I/O error, dev sdb, sector 0
[  281.248484] Buffer I/O error on device sdb, logical block 0
[  281.248498]  unable to read partition table
[  281.253089] sd 6:0:0:0: [sdb] Attached SCSI removable disk
knoppix@Microknoppix:~$ dmesg | tail
[  281.246229] Buffer I/O error on device sdb, logical block 0
[  281.246244] ldm_validate_partition_table(): Disk read failed.
[  281.248450] sd 6:0:0:0: [sdb] Device not ready
[  281.248455] sd 6:0:0:0: [sdb] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[  281.248462] sd 6:0:0:0: [sdb] Sense Key : Not Ready [current] 
[  281.248470] sd 6:0:0:0: [sdb] Add. Sense: Medium not present
[  281.248479] end_request: I/O error, dev sdb, sector 0
[  281.248484] Buffer I/O error on device sdb, logical block 0
[  281.248498]  unable to read partition table
[  281.253089] sd 6:0:0:0: [sdb] Attached SCSI removable disk
knoppix@Microknoppix:~$ dmesg | tail
Hoffe du kannst etwas brauchbares damit anfangen :)

Gamepower
10 Bit
Beiträge: 1613
Registriert: Do Aug 03, 2006 19:49
Wohnort: Pasewalk
Kontaktdaten:

Re: IniMaker - Nun SD Karte defekt

#22 Beitrag von Gamepower » Di Jan 12, 2010 10:50

deine inimaker spielereien haben den bootsector, bzw. die partitionstabelle zerschossen...

verusche mal, mit einem partitionierungs proggi, die partition wieder her zu stellen, oder eine neue anzulegen... anschliessend formatieren und du hast eine funktionierende sd-card.

IsSuE
6 Bit
Beiträge: 100
Registriert: Do Jan 12, 2006 19:38
Wohnort: Oberoesterreich

Re: IniMaker - Nun SD Karte defekt

#23 Beitrag von IsSuE » Di Jan 12, 2010 11:52

jup deine partitionstabelle is hinueber.
du solltest die karte aber mit mkfs -t vfat /dev/sdb wieder formatieren koennen.
check aber vorher noch ob die karte eh wieder /dev/sdb geworden ist mit dmesg

Benutzeravatar
momosxp
8 Bit
Beiträge: 281
Registriert: Di Apr 08, 2008 09:34
Kontaktdaten:

Re: IniMaker - Nun SD Karte defekt

#24 Beitrag von momosxp » Di Jan 12, 2010 13:31

knoppix@Microknoppix:~$ mkfs -t vfat /dev/sdb
mkfs.vfat 3.0.6 (04 Oct 2009)
mkfs.vfat: Device partition expected, not making filesystem on entire device '/dev/sdb' (use -I to override)

Benutzeravatar
torro
8 Bit
Beiträge: 365
Registriert: Fr Jan 30, 2009 22:33
Wohnort: Aachen

Re: IniMaker - Nun SD Karte defekt

#25 Beitrag von torro » Di Jan 12, 2010 14:00

"mkfs -I -t vfat /dev/sdb"
steht da doch

Benutzeravatar
momosxp
8 Bit
Beiträge: 281
Registriert: Di Apr 08, 2008 09:34
Kontaktdaten:

Re: IniMaker - Nun SD Karte defekt

#26 Beitrag von momosxp » Di Jan 12, 2010 22:28

Danke euch für die ganzen Tipps.
Es geht leider immer noch nicht. Aber glaube, wir kommen der Sache näher:

Code: Alles auswählen

knoppix@Microknoppix:~$ mkfs -I -t vfat /dev/sdb
mkfs.ext2: Unzulässige Inode-Größe - -t
knoppix@Microknoppix:~$ mkfs -t vfat -I /dev/sdb
mkfs.vfat 3.0.6 (04 Oct 2009)
mkfs.vfat: failed whilst writing reserved sector
knoppix@Microknoppix:~$ mkfs -t vfat -I /dev/sdb1
mkfs.vfat 3.0.6 (04 Oct 2009)
/dev/sdb1: No such file or directory
knoppix@Microknoppix:~$ mkfs -t vfat -I /dev/sdb2
mkfs.vfat 3.0.6 (04 Oct 2009)
/dev/sdb2: No such file or directory

Gamepower
10 Bit
Beiträge: 1613
Registriert: Do Aug 03, 2006 19:49
Wohnort: Pasewalk
Kontaktdaten:

Re: IniMaker - Nun SD Karte defekt

#27 Beitrag von Gamepower » Mi Jan 13, 2010 05:15

lass dir mal, mit "mount", alle vorhandenen und eingebundenen laufwerke und partitionen anzeigen.... das ganze postest du hier auch mal...

IsSuE
6 Bit
Beiträge: 100
Registriert: Do Jan 12, 2006 19:38
Wohnort: Oberoesterreich

Re: IniMaker - Nun SD Karte defekt

#28 Beitrag von IsSuE » Mi Jan 13, 2010 10:08

Okay: hatte deine SD-Card Partitionen? Check das mit (als root) fdisk -l /dev/deinespeicherkartelautdmesg
Ich wuerd das jetzt mal so angehen: die Karte mit random werten von dd befuellen lassen, zb hiermit: dd if=/dev/urandom of=/dev/speicherkarte
dd sollte dir hier IO errors melden, bzw ob es ueberhaupt klappt oder nicht. wenn dd failed ist die karte wahrscheinlich hinueber!

und danach entweder mit mkfs -t vfat oder mit mkdosfs fat32 draufbuegeln.

Benutzeravatar
Wizmaster
6 Bit
Beiträge: 122
Registriert: Mi Jul 15, 2009 23:58
Wohnort: Niederoesterreich

Re: IniMaker - Nun SD Karte defekt

#29 Beitrag von Wizmaster » So Jan 17, 2010 16:37

versuch mal g-parted; funzt eigentlich sehr gut das progg; is ne live-CD mit
blackbox/fluxbox GUI und kann nur für partitionieren, formatieren usw verwendet werden;

zur not muß du deine SD-Card über den "USB-Device-mounter (nenn ich mal so)" einbinden;
das progg g-parted beenden (das progg in der gui, nicht die live-CD sitzung) und einfach
2x auf "USB device mounten" klicken; dann läuft das terminal, hier mußte aba gar nix machen.
g-parted starten und rechts oben im fenster deine SD-CARD wählen; alles andere erklärt sich
von alleine; vorsicht, du mußt auf alle fälle das richtige wählen...ansonsten kann es passieren
das du deine HDD formatierst!!!


zur info: das progg g-parted popt automatisch auf wenn die live-cd sitzung fertig geladen wurde;
also solltest du nen card-reader beim booten mit der SD-Card scho eingesteckt haben, müßte es
das progg von alleine erkennen;

hier der direkte download-link klick
...
Bild

PatrikHas
1 Bit
Beiträge: 2
Registriert: Di Jan 09, 2018 07:23

Re: IniMaker - Nun SD Karte defekt

#30 Beitrag von PatrikHas » Di Jan 09, 2018 08:12

Kann die Karte noch bei dem PC erkannt? Hast du Datenrettungssoftware ausprobiert? Zuerst probier mal aus, die Karte an den PC schließen, mit Hilfe eine Datenrettungssoftware die Karte zu scannen, um die Dateien drauf zu retten. Ich empfehle das Tool Recuva. Es ist kostenlos. Auch kann man Data Recovery Wizard verwenden. Es hat mir gute Dienst geleistet. **link von Moderator Ingo entfernt**

Antworten

Zurück zu „Wiz - Hilfe!“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast